见:http://www.cnic.cn/xw/kydt/201305/t20130503_3831555.html
LISP协议
身份与位置信息分离,改善IP协议的扩展性、移动性支持问题
EID为身份信息,RLOC为位置信息,
在BR接入节点处做封装,BR1需要找MS查EID2 -> RLOC2的映射信息
国际化域名注册
由于存在“工商银行.中国”、“工商銀行.中國”这种同义域名,如果要防钓鱼,最好注册一个之后,其他同义域名全部打包自动注册,不准动。类似于别名机制,多个同义域名共享同一份注册信息。
多语种邮件 RFC6531,RFC6532
smtp头支持utf8编码格式的unicode字符
下一代whois
支持结构化的信息查询,更新(谢天谢地)
DANE:利用DNS系统做TLS的CA设置,RFC 6394,RFC 6698
DNS系统新增一个TLSA的RR记录,限制该域名对应的TLS服务器可信任的CA
2013年5月13日星期一
2013年2月18日星期一
笔记:整合IP地址库数据
整合IP地址库数据:
1)A 文件:ip_c, state(国家), prov(省份), isp(运营商)
2)B 文件:ip_start_inet、ip_end_inet、state, prov, area(地区)
提取出A文件中的ip_c,去B文件里查area,得到文件C:
ip_c, start_inet , end_inet, b_state, b_prov, b_area
这里注意分批查节省内存,比如每次查5000个c段之类的
合并文件A和文件C,得到文件D(按start_inet递增写入):
ip_c, start_inet , end_inet, state, prov, area, isp
最终的state/prov/area是文件A与文件C里的地址信息PK结果,指定一些附加检查条件即可
遍历文件D,检查相邻两行是否具有完全相同的state, prov, area, isp信息,并且前一行的end_inet + 1 是否等于后一行的 start_inet
start_inet , end_inet, state, prov, area, isp
1)A 文件:ip_c, state(国家), prov(省份), isp(运营商)
2)B 文件:ip_start_inet、ip_end_inet、state, prov, area(地区)
提取出A文件中的ip_c,去B文件里查area,得到文件C:
ip_c, start_inet , end_inet, b_state, b_prov, b_area
这里注意分批查节省内存,比如每次查5000个c段之类的
合并文件A和文件C,得到文件D(按start_inet递增写入):
ip_c, start_inet , end_inet, state, prov, area, isp
最终的state/prov/area是文件A与文件C里的地址信息PK结果,指定一些附加检查条件即可
遍历文件D,检查相邻两行是否具有完全相同的state, prov, area, isp信息,并且前一行的end_inet + 1 是否等于后一行的 start_inet
- 如果是,则更新start_inet、end_inet,合并成一行,从新行开始继续遍历
- 如果不是,则从后一行开始,继续遍历
start_inet , end_inet, state, prov, area, isp
2012年11月20日星期二
Perl : ip 与 inet 十进制字符串互转
use Socket;
my $ip = '202.38.75.11';
my $inet_str = unpack('N', inet_aton($ip));
my $ip_re = inet_ntoa(pack('N', $inet_str));
订阅:
博文 (Atom)